AjaxToolkit Error

Aug 31, 2010 at 6:51 PM

When navigating to the "Settings" tab in the Admin menu, I get this error:

"A critical error has occurred.
Unknown server tag 'ajaxToolkit:ColorPickerExtender'"

The AjaxControlToolkit .dll exists in my bin folder, and the default FAQ module on my site has working Ajax functionality.
Is there anything I have to declare, edit, etc. to ensure the ColorPicker - or the toolkit in general - is recognized?

Thanks.

Coordinator
Sep 1, 2010 at 8:56 AM

Have you deleted from AdminSettings.ascx this code ?

<%@ Register Assembly="AjaxControlToolkit" Namespace="AjaxControlToolkit" TagPrefix="ajaxToolkit" %>

 

 

What is your AjaxControlToolkit version in the bin folder ?

Sep 1, 2010 at 1:59 PM

Double-checked the code & it is still there.

 The toolkit version is 1.0.20229.0 (1.0.20229.20821) in <wwwroot>\bin.

The ANM bin folder contains "System.Web.Ajax.pdb", "AjaxControlToolkit.pdb", and three REFRESH files, for what it's worth.

Coordinator
Sep 1, 2010 at 2:52 PM
Edited Sep 1, 2010 at 2:52 PM

It is an old version of the toolkit, replace it with 3.0.30930.0

You can download it from here: http://ajaxcontroltoolkit.codeplex.com/releases/view/33804

Sep 1, 2010 at 3:34 PM
Edited Sep 1, 2010 at 3:35 PM

Odd, my site was created months after that version came out. I never thought to look for a newer version. I should have checked.
As you prescribed, simply upgrading to 3.0.30930.0 fixed it. Thanks!

(Any reason not to upgrade to 40412?)