Problems Installing

Feb 16, 2011 at 4:07 PM

Hi,

I'm running ANM on a Win 2k3 r2 machine, asp.net 4 with SQL express. When I navigate to the install aspx page I just get a connecting.... message in IE 8.

The location of the ANM files has read / write access for the network service

IIS is setup to allow anonymous access in the authentication control and execute permissions are scripts only

Thanks for looking.

Coordinator
Feb 17, 2011 at 7:37 AM

Some questions... have you tried with another browser ? Do you have the host name and credentials with DBO access to the database ? And users have full permissions on the folder ?

Do you have IIS 7 on your machine ?

Feb 17, 2011 at 8:36 AM
Edited Feb 17, 2011 at 8:45 AM

 

I've tried IE8 on two machines, IE6 & FF. FF gives the error message (The page isn't redirecting properly, Firefox has detected that the server is redirecting the request for this address in a way that will never complete.)

The host name is on an internal only network, but the anm0103 folder has the following security accounts:

asp.net machine account = mod, r&e, lfc, r&w

network service = full control

users = r&e, lfc, r

 

Its IIS v6, I don't think v7 is available for Win2k3. The ISS web service extension is set to allow asp.net 4.0 and prohibit net 1.1 and active server pages. The virtual directory is set up to use .net 4.0 also

 

Feb 17, 2011 at 8:39 AM

also i've created a temp index.html file with a simple hello world message which displays when i navigate to the site, but when i try the install.aspx then nothing happens, even if there was a problem with the database then the page should at least load.

Coordinator
Feb 17, 2011 at 11:36 AM
Edited Feb 17, 2011 at 2:32 PM
norvile wrote:

if there was a problem with the database then the page should at least load.

I agree.

 

Try to open web.config and change:

customErrors mode="Off"

compilation debug="true"

 

Now you should get more information on the error.

I think the problem is IIS6, because I have tested the application on IIS7 (or higher) and for IIS6 should be done some changes at web.config.

May 23, 2011 at 6:02 PM

can you help max... i am trying to run all news manager on IIS 6.. but unable to do so.. it give error message

Error!!! Check the web.config connectionString or check you have the host name and credentials with DBO access to the database.

although same connection i tried on different application and it worked fine.. i tried to run these commands

 

exec sp_grantlogin 'NT Authority\Network Service' 
use news
exec sp_grantdbaccess 'NT Authority\Network Service' 
exec sp_addrolemember 'db_owner', 'NT Authority\Network Service'

exec sp_grantlogin 'IIS APPPOOL\DefaultAppPool' 
use news
exec sp_grantdbaccess 'IIS APPPOOL\DefaultAppPool'

 

all went well only 3 last IIS APPPOOL\DefaultAppPool it say it does not exits... i am keep getting same error message when trying to install.. please help me in this regard.. will be very thankful to you

Coordinator
May 23, 2011 at 7:31 PM

with IIS6, try to run this

 

exec sp_grantlogin 'MachineName\ASPNET' 
use database_name  
exec sp_grantdbaccess 'MachineName\ASPNET' 
exec sp_addrolemember 'db_owner', 'MachineName\ASPNET'

 

replace MachineName and database_name

 

And check if you have full permissions on the folder